Pidgin 2.7.1 Error Segmentation Fault Ubuntu Lucid [Solved]

Setelah Install ulang system saya, karena saya ingin merubah partition table hardisk saya yang ingin saya jadikan dual sistem Operasi Ubuntu dengan Distro linux lain. Setelah proses backup file selesai kemudian saya lakukan fresh install system ubuntu, seperti biasanya saya mengistall beberapa aplikasi yang diperlukan seperti browser, aplikasi pemutar musik, dan internet messenger. Kebetualan saya tidak menggunakan empathy sebagai Internet Messenger di system ubuntu. saya lebih senang menggunakan pidgin dari pada emphaty karena di Pidgin terdapat banyak plugin yang banyak. Setelah Installasi Pidgin selesai saya lakukan upgrade ke pidgin karena Pidgin bawaan ubuntu Lucid default masih menggunakan pidgin 2.8.1 kemudian saya upgrade menggunakan cara saya pada artikel sebelumnya saya menemui kendala pada saat load contact list pada Pidgin 2.7.1 kemudian saya cari errornya dengan memanggilnya dengan menggunakan Terminal terdekat :D Setelah saya panggil disana keluar error yaitu Segmentation Fault error ini disebabkan karena pidgin gagal memuat contact list ini mungkin bugs dari souces yang saya ambil dari ppa Pidgin, setelah googling sana sini sempat mampir ke blog teman yang membahas Pidgin Segmentation Fault ternyata gagal juga, kemuadian saya masuk saja ke laman http://pidgin.im kemudian saya unduh paket dari souces pidgin asli yang sudah setabil :D setelah saya coba dan ternyata error Pidgin Segmentation Fault pun tidak ada lagi dan pidgin bisa jalan lancar jaya kembali. Tahapan memperbaikinya dengan cara berikut ini.

Hapus Pidgin lama dengan mengetikkan perintah berikut pada Terminal anda

$ sudo apt-get remove pidgin pidgin-data pidgin-libnotify pidgin-ppa

Hapus sources.list pidgin lama dengan mengetikkan perintah berikut :

$ sudo rm -rf /etc/apt/sources.list.d/pidgin-ppa.list

$ sudo rm -rf /etc/apt/sources.list.d/pidgin-ppa.list.save

kemudian masukkan alamat souces.list dari ppa resmi Pidgin, ketikkan perintah berikut :

$ sudo gedit /etc/apt/sources.list

pasangkan alamat sumber pada text editor gedit :

deb http://ppa.launchpad.net/pidgin-developers/ppa/ubuntu lucid main
deb-src http://ppa.launchpad.net/pidgin-developers/ppa/ubuntu lucid main

Simpan dan keluar dari gedit kemudian muat ulang repository dengan mengetikkan perintah berikut

$ sudo apt-get update

setekah update repository selesai kemudian unduh paket Pidgin PPA resmi :D

$ wget -c http://launchpadlibrarian.net/48617414/pidgin-ppa_0.0.2_all.deb

proses mengunduh selesai kemudian Install Pidgin 2.7.1

$ sudo dpkg -i pidgin-ppa_0.0.2_all.deb

kemudian tunggu hingga proses installasi selesai dan Pidgin siap digunakan dengan lancar jaya :D

Semoga Bermanfaat

Postingan Terkait :



Radite Putut

Blogger dengan kerja sambilan Designer Freelancer.

3 comments:

Himawan Mahardianto said...

maaf mas, saya sudah ikuti langkah di atas tapi koq hasilnya masih error ya, ini pesan errornya:
Jun 30 08:43:36 himawan-netbook kernel: [ 1448.749511] pidgin[2974]: segfault at 5f ip 0080f248 sp bf8561fc error 4 in libc-2.11.1.so[6f7000+153000]

dan pidgin yang terinstall adalah pidgin 2.7.2 dev, bukan 2.71 dengan langkah2 yang sudah disebutkan diatas ...
mohon solusinya, terima kasih sebelumnya

radithTux said...

@himawan : Intinya itu adalah menghaus semua paket dan libraly pidgin yang lama kemudian digantikan dengan pidgin yang stabil misalnya saya mengambil sources yang saya pakai di atas :D

rauff risharasakti said...

Masih saja gak bisa mas :(